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Assignments 

About Assignments 
You can create one assignment at a time as you progress through the term, or you can set 
up assignments for the entire term before the term starts. Having all assignments for the 
term before the term starts does not change how grades appear. The Final Grade that 
appears on the Scoresheet reflects an average grade for only the assignment scores that 
have been entered. 

Before setting up an assignment, consider how you will score the assignment: 

x Do you want to record the score as points, a percentage, or letter grade? 

x How many points is the assignment worth? 

x How do you want to weight the assignment? 

x Do you want to include the assignment in final grade calculation? 

Include in Final Grade 
When setting up assignments, you can use the Include in Final Grade checkbox to 
indicate whether an assignment should be included in calculating final grades. The value set 
for a category is used as a default for all assignments within that category, but may be 
overridden on an assignment-by-assignment basis. 

If an assignment is included in calculating final grades and impacts the final grade, it must 
be published in order for parents and students to view it. The Publish Assignment pop-up 
menu cannot be set to Never. For more information, see Publish Assignments. 

Weighting 
Assignment setup may involve weighting; however, weighting is not required. Weighting 
gives particular assignments, whether points, percentage, or letter grades, more value than 
others when determining final grades. The weight value is used to multiply the points 
earned and the points possible. 

Extra Credit 
You can determine the extra credit points on the Assignments window. PowerTeacher 
gradebook takes the total sum of Points Possible and Extra Points to determine the 
maximum points available on the assignment. When entering the score on the Scoresheet 
or Score Inspector, you cannot enter a value greater than the maximum score that appears 
on the Assignments Detail window in the Max field. 
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Standards Based Grades 
You can assign any number of standards to an assignment, and score each standard 
separately. Reporting on standards is also available. For more information, see About 
Standards. 

Add Assignments 
You can add assignments from the Assignments window or the Scoresheet window using the 
Plus (+) button. Alternately, you can right-mouse click if you are using a two-button 
mouse. 

How to Add an Assignment 
1. Select a class from the Classes pane. 

2. Click the Assignments tab. The Assignment Detail window appears. 

Note: To increase or decrease the size of the contents within the window, choose 
View > Zoom. 

3. Click the Plus (+) button. The new Assignment Detail window appears. 

4. Optionally, click Add Web Link to add a Web link to the class description. The Add 
Web Link dialog appears. 

5. Enter the required information. 

6. To make the assignment visible to parents, see Show Assignments. 

7. Click Save. 

View Assignments 
To view assignments for a particular class, select the class and click the Assignments tab. 

How to View Assignments 
1. Select a class from the Classes pane. 

2. Click the Assignments tab. The Assignment window displays class assignments 
and basic information about each assignment. 

Edit Assignments 
You can edit an assignment from the Assignments window or the Scoresheet window. 

How to Edit an Assignment 
1. Select a class from the Classes pane. 

2. Click the Assignments tab. The Assignment window appears. 
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Note: To increase or decrease the size of the contents within the window, choose 
View > Zoom. 

3. Double-click the assignment you want to edit. The Assignment Detail window 
appears. 

4. Optionally, click Add Web Link to add a Web link to the class description. The Add 
Web Link dialog appears. 

5. Edit the information as needed. 

6. To make the assignment visible to parents, see Show Assignments. 

7. Click Save. 

Note: If Points Possible is modified for an assignment where student point-based 
scores exists, the Points Possible Has Changed window appears. You can either 
click Keep Scores to keep the scores as-is or click Adjust Scores to adjust them 
based on the new points possible. 

Copy Assignments 
You can use the Copy Assignments function to copy assignments from one class to other 
classes. You can copy assignments from the Assignments window or the Scoresheet 
Assignments window using the gradebook menu bar. Alternately, you can right-mouse click 
if you are using a two-button mouse. 

When copying an assignment, the assignment details and publish settings are copied to the 
new assignment, with the exception of the assignment score. If an assignment with same 
name or abbreviation already exists in the class you are copying the assignment to, such as 
“FirstHW”, the suffix “_<next larger number>” is appended to the assignment name or 
abbreviation, such as “FirstHW_1." 

How to Copy Assignments 
1. Select a class from the Classes pane. 

2. Click the Assignments tab. The Assignment window appears. 

Note: To increase or decrease the size of the contents within the window, choose 
View > Zoom. 

3. Select an assignment. 

4. Either choose Tools > Copy Assignments from the gradebook menu bar or right-
mouse click and select Copy Assignments. The Copy Assignments dialog appears. 

5. Edit the information as needed. 

6. Click OK. The assignment or assignments are copied to the selected classes. 

7. Click Save. 

Delete Assignments 
You can delete an assignment from the Assignments window or the Scoresheet window 
using the Minus (-) button. Alternately, you can right-mouse click if you are using a two-
button mouse. 
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How to Delete an Assignment 
1. Select a class from the Classes pane. 

2. Click the Assignments tab. The Assignment window appears. 

Note: To increase or decrease the size of the contents within the window, choose 
View > Zoom. 

3. Select the assignment you want to delete. The Assignment Detail window 
appears. 

4. Click the Minus (-) button. The Delete Assignment window appears. 

If an assignment does not have scores, the Delete Assignment window states, "Are 
you sure you want to delete assignment [name]?" 

If an assignment has scores, the Delete Assignment window states, "This 
assignment has scores. Are you sure you want to delete assignment [name] and all 
associated scores?" 

5. Click Yes. The assignment no longer appears on the Assignment window. 

Filter Assignments 
By default, the Assignments window displays assignments for all categories for the entire 
length of the class. You can customize the appearance on the Assignments window using 
filtering. Filtering allows you to indicate which assignments appear based on reporting term, 
category, or combination of. 

How to Filter Assignments 
1. Select a class from the Classes pane. 

2. Click the Assignments tab. The Assignment window appears. 

Note: To increase or decrease the size of the contents within the window, choose 
View > Zoom. 

3. Do one of the following: 

x Choose a reporting term, week, or month from the Reporting Term pop-up 
menu. The Scoresheet window refreshes and displays only those assignments 
and scores with a due date that falls within that selected reporting term, 
week, or month. 

Note: The selected reporting term becomes the new default setting. 

x To filter by category, see Filter by Categories. 

Sort Assignments 
By default, the Assignments window displays assignments in ascending order by name. 
Using the column headings, you can sort data in ascending or descending order based on 
the column heading you select. 
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How to Sort Assignments 
1. Select a class from the Classes pane. 

2. Click the Assignments tab. The Assignment window displays the assignments in 
ascending order by name. 

Note: To increase or decrease the size of the contents within the window, choose 
View > Zoom. 

3. Click a column heading to sort the Assignment window by that column heading. 
When sorted in ascending order, an upward pointing arrow appears in the column 
heading. When sorted in descending order, a downward pointing arrow appears in 
the column heading. 

Publish Assignments 
After entering an assignment, assignment information may be shared with administrators, 
parents, and students. In order for parents and student to view assignment information, 
you need to publish the assignment from either from the Assignments window or the 
Scoresheet window. 

How to Publish an Assignment 
1. Select a class from the Classes pane. 

2. Click the Assignments tab. The Assignment window appears. 

Note: To increase or decrease the size of the contents within the window, choose 
View > Zoom. 

3. Select the assignment you want to publish. The Assignment Detail window 
appears. 

4. Click Publish. Assignment publishing information appears. 

5. From the Publish Assignment pop-up menu, choose when to publish the 
assignment: Immediately, On Specific Date, Days Before Due, or On Due 
Date. 

6. If you chose On Specific Date, enter the date the assignment should appear in the 
Date On field using the format mm/dd/ yyyy, or click the Calendar icon to select a 
date. 

7. If you chose Days Before Due, enter the number of days the assignment should 
appear prior to the date that it is due in the Days Before Due field. 

8. Click Save. 

Publish Assignment Scores 
When publishing an assignment, assignment score information may be shared with 
administrators, parents, and students. In order for parents and student to view assignment 
score information, you need to publish the assignment score from either from the 
Assignments window or the Scoresheet window. 



PowerTeacher Gradebook User Guide 

Assignments 71 

How to Publish Assignment Scores 
1. Select a class from the Classes pane. 

2. Click the Assignments tab. The Assignment window appears. 

Note: To increase or decrease the size of the contents within the window, choose 
View > Zoom. 

3. Select an assignment. The Assignment Detail window appears. 

4. Click Publish .Assignment publishing information appears. 

5. Select the Publish Scores checkbox. 

Note: If the Publish Assignment pop-up menu is set to Never, do not select the 
checkbox. 

6. Click Save. 

Hide Assignments 
If you do not want share assignment information with parents and students, you can choose 
not to publish an assignment either from the Assignments window or the Scoresheet 
window. 

Note: If an assignment is included in calculating final grades and impacts the final grade, it 
must be published in order for parents and students to view. The Publish Assignment 
pop-up menu cannot be set to Never. For more information, see Publish Assignments. 

How to Hide an Assignment 
1. Select a class from the Classes pane. 

2. Click the Assignments tab. The Assignment window appears. 

Note: To increase or decrease the size of the contents within the window, choose 
View > Zoom. 

3. Select the assignment you do not want published. The Assignment Detail window 
appears. 

4. Click Publish. Assignment publishing information appears. 

5. Choose Never from the Publish Assignment pop-up menu. 

6. Click Save. 

Hide Assignment Scores 
If you do not want share assignment score information with parents and students, you can 
choose not to publish an assignment score either from the Assignments window or the 
Scoresheet window. 

How to Hide Assignment Scores 
1. Select a class from the Classes pane. 
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2. Click the Assignments tab. The Assignment window appears. 

Note: To increase or decrease the size of the contents within the window, choose 
View > Zoom. 

3. Select an assignment. The Assignment Detail window appears. 

4. Click Publish. Assignment publishing information appears. 

5. Deselect the Publish Scores checkbox. 

6. Click Save. 


